Update Your Flash Player

by Jeff Atwood

on May 19, 2008

I noticed that a few people have had trouble with the embedded flash podcast player in the podcast posts. They reported that Joel and I sounded like chipmunks.

I was able to duplicate this problem using a virtual machine and a stock version of Windows XP. If you're having the chipmunk playback problem, you have an out-of-date installation of Adobe Flash. That's the cause.

I strongly recommend Updating your Flash Player to the latest version. Bear in mind, if you regularly use more than one browser, you must update Flash individually for each browser you use.

If you're wondering what version of Flash you have installed, use the official Adobe online Flash version number checker. It's reporting I have version 9.0.115.0 installed at the moment.

Updating Flash isn't just a good idea to correct the playback issues with our podcast audio player -- it's also a good idea because there are serious security vulnerabilities in old versions of Flash, too. If your Flash is version 9.0.48.0 or earlier, you're subject to at least 9 critical security vulnerabilities according to Adobe! And remember, these are the worst kinds of vulnerabilities -- the ones that can compromise your system by simply visiting the wrong web page. Scary stuff.

Let's practice safe computing and get that Flash player updated!